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Exploring Firefox 
 
 
Firefox:  the beginning… 
 
Mozilla was the original code name for Netscape Navigator during its development stages. 
 
On January 23, 1998, Netscape Communications announced that it would provide 
Netscape products free of charge and that the source code for communicator would also be 
free.  Using the free code supplied by Netscape, “Mozilla.org”, a group chartered to provide a 
central point of contact and community for those interested in using or improving the source 
code, wanted to build the most useful web browser for Windows, Linux, and Mac OS X. 
 
What does Firefox offer? 
 
Popup Blocking – Stop annoying popup ads with this built in blocker 
 
Tabbed Browsing – view more than one web page at a time – have multiple “home” pages. 
    
Privacy and Security – Firefox does not load “active X” controls – these are what spyware 
uses to download programs onto your pc. 
 
Smarter Search = Google is built into Firefox.  There are also quicksearch links to 
Dictionary.com. stock quotes, and Wikipedia. 
 
Live Bookmarks – You can access the world’s leading headlines through your bookmarked 
RSS feeds. 
 
Hassle-free downloading – Downloaded files are automatically saved to your desktop to 
make them easier to find. 
 
Customized interface – Firefox allows you to customize toolbars, add buttons, install 
extensions, and add different themes. 
 
Developer tools – Firefox comes with a standard set of developer tools including JavaScript 
and CSS error/warning consoles, and an optional document inspector that gives detailed 
insight about your pages. 
 



Getting Mozilla Firefox 

1. To download Firefox, go to getfirefox.com and select "Free Download" 
2. When asked to 'Open the file' or 'Save it to your computer', select 'Open' to begin 

installation. If you save it to your computer, save the file to your desktop and double-
click the Firefox Setup 1.0.6.exe to start the install. 

 

Browser Plug-ins, Add-ons, and Toolbars 

Many of the plug-ins, add-ons, and toolbars that you may have installed for Internet 
Explorer are also available for Mozilla Firefox, including: 

• Macromedia Flash Player, Apple QuickTime, Real Networks RealPlayer, Windows 
Media Player, Adobe Acrobat Reader, and Sun Microsystems Java Plug-in 

• Google Toolbar 

There are also over 120 extensions that are available for Mozilla Firefox to extend the 
functionality of Firefox even more. 

Firefox and Internet Explorer Terminology Differences 

Internet Explorer Firefox 

Internet Options Options 

Temporary Internet Files Cache 

Favorites Bookmarks 

Address Bar Location Bar 

Refresh Reload 

Links Bar Bookmarks Toolbar

Explorer Bar Sidebar 

Copy Shortcut Copy Link Location

Save Target As Save Link As 

 



Tips From MozillaZine Knowledge Base 

These tips are reprinted with permission from Firefox support.  
(http://forums.mozillazine.org/viewtopoic.php?t=170970) 

 
To enable pop-up blocking:  

1. Click the Edit menu.  
2. Choose Preferences.  
3. Double-click the category you want to configure in the left-hand pane. In this case, 

double-click Privacy and Security.  
4. Click "Pop-up Blocking" in that same pane.  
5. Check "Block Pop-up Windows".  

Mouse Tips 

Middle Click 

Note: Two-button mouse  
A Mouse Wheel Click can be used wherever a Middle Click is required in the tips below. For 
those without middle mouse buttons or mouse wheel, clicking both mouse buttons at the 
same time also mimics the Middle Click function. Many Laptops mimic the Middle Click 
function if you click the right and left pads at the same time.  

Opening Tabs 

Middle Click on a link will open that link in a new tab. This principle will work in many 
other situations, such as on bookmarks, bookmark folders, history items, page images, and 
also on toolbar buttons such as Home, the Back and Forward buttons, Personal Toolbar 
items, and the Throbber [the 'busy' icon at the top-right]. Moreover, you can even Middle 
Click on menu items which represent web page (such as items from the Back, Forward, 
Bookmarks and Go menus) to open them in a new tab.  

Closing Tabs 

Middle Click on a tab marker will close that tab.  
Note that user preference "middlemouse.contentLoadURL" must be set to false for this to 
work. To verify that the preference is set to false, enter "about:config" in the Firefox address 
bar, enter the preference "middlemouse.contentLoadURL" in the filter, and verify the setting 
appears as 'false' in the 'value' column. If it is set to 'true', double-click anywhere along the 
row and it will revert to 'false'. Middle-clicking on a tab to close it will now work.  

Double Click 

Opening Tabs on theTab Bar 

Double Clicking empty space on the Tab Bar will open a 'New Tab.  



Download Manager 

Double Clicking a file entry in the Downloads Manager will open/launch the file (provided 
you haven't moved it yet).  

Right Click 

Customize the toolbars 

You can adjust your toolbars to your liking. Right click on any toolbar, and select 
'Customize'. While this dialogue is up, you can move buttons around on your toolbars by 
click-and-drag to the new location. The window that pops up when you do this is a holding 
area for unused icons. You can drag any item from it onto your toolbars to have it made 
available, and you can drag any icon from your toolbars onto this box to hide that icon 
completely.  
Tip 

Some toolbar items, such as the Location bar, will expand to take up all available 
space.  

Create a keyword bookmark 

Right clicking in a search box (such as the search box on the left of this page) and selecting 
'Add a Keyword for this Search' lets you make an interactive keyword bookmark.  
Here is how it works 

Give it a name, such as 'mozillaZine Knowledge Base search'  
Now, assign a keyword to it, such as 'mozkb'  
Click 'OK'  

From now on, you can search mozillaZine Knowledge Base (or any other search box you 
used for this) from your address bar like this 

Enter 'mozkb search topic' in your address bar and click Go!  

View selection source 

Right-click on a highlighted area of a page (obtained by click-and-dragging the mouse, for 
example) and choose 'View selection source' to display the source code for the selected part 
of the page only.  

Drag and Drop 

Moving bookmarks and folders 

You can change a bookmark's position in a folder or move it from one folder to another or 
move it to another position on the toolbar by dragging it to your desired position. A folder 
can be moved the same way but you must hold down the Shift key while dragging. To copy 
a folder, hold the Ctrl key while dragging.  



Icons 

You can bookmark the current page by dragging the icon from the location bar to your 
Bookmarks folder. You can also drag it to the desktop to make an icon for that page. Drag a 
text file, a link, a picture, etcetera... from your folders or your desktop to Firefox and it will 
open in Firefox!  

Links 

"Click-and-drag" a bookmark to the main content window (which is the biggest on the 
Firefox user interface), so you can open it in a new tab! Dragging a link onto a new tab will 
open the link in the new tab.  

Downloading links 

Drag any link to the Download Manager Window to add and download the link. You can 
also directly download anything from a page by drag and dropping it onto the "Downloads" 
icon in your toolbar (provided you put it there through Customize).  
  

Tabs 

Navigate through tabs 

Ctrl+TAB or Ctrl+PageUp lets you navigate in the tabs to the right.  
Ctrl+Shift+Tab or Ctrl+PageDown lets you navigate in the tabs to the left  

Tip 
These wrap.  
Ctrl and a number key will go to the tab indicated by the number.  
(e.g. Ctrl+3 will go to the third tab from the left)  

 

Opening and closing tabs 

CTRL+T opens a new tab  
CTRL+W closes current tab  

Font Size 

Hold Ctrl AND press + or - to change font size.  
(the font changing on IE is 5 sizes. FF has dozens of size settings)  
 
 
 



Bookmark or save multiple tabs 

Bookmark all open tabs 

You can bookmark all open tabs into a new bookmark folder. Open the Add Bookmark 
dialog (Ctrl+D or "Bookmarks -> Bookmark This Page" or "Bookmark this page" in context 
menu). Check the "bookmark all tabs in a folder" checkbox. Change the name to be the 
name of the new bookmark folder you wish to create, and then select a parent folder. Finally, 
click OK.  
A folder with bookmarks to all open tabs will be created. You can later reopen the tabs you 
saved by middle-clicking the folder or selecting the "Open in Tabs" menu item.  
 
Import bookmarks 
 
Firefox has Import Wizard ("File -> Import") which is capable of importing bookmarks 
automatically. Only use these instructions if Import Wizard doesn't work.  

From Internet Explorer 

On Windows, Firefox automatically imports IE Favorites when you install the program or 
create a new profile.  
You can install Plain Old Favorites extension to use your IE favorites directly in Firefox.  
To manually import your IE Favorites into Firefox or Mozilla Suite, first you have to export 
them from within IE, then import them using Firefox.  

To export from IE: 

1. Run Internet Explorer.  
2. Go to "File > Import and Export...", then click Next.  
3. Select "Export Favorites", click Next, click Next again (unless you only want to 

export a subfolder of your Favorites, in which case, select that subfolder now).  
4. Click "Export to a File or Address", then click Browse and save the bookmarks onto 

your desktop. (Any file name and location will work, as long as you remember where 
you saved it.)  

5. Click Next, then Finish, and you're done.  

To import them into Firefox/Mozilla Suite: 

1. Run Firefox or Mozilla Suite.  
2. Go to "Bookmarks -> Manage Bookmarks".  
3. Once inside the Bookmark Manager, go to the "File -> Import -> From File" 

(Mozilla Suite users select "Tools -> Import...").  
4. Browse to the file you saved your IE Favorites in, click Open. Then rearrange 

everything to your heart's content.  

  



From Safari 

You need third-party software to export Safari bookmarks. Here's a tool, called Safari 
Bookmark Exporter: Versiontracker.com mirror Macupdate.com mirror  
 
This does now work with Tiger.  
Sorting bookmarks alphabetically 
 
(Redirected from Sorting Bookmarks Alphabetically (Firefox)) 
There are several ways to sort your bookmarks.  

• In recent Firefox versions you can also use built-in solution (only alphabetizes the 
files in the one folder):  

o Method 1  
1. Click on the Bookmarks menu option  
2. Right click any file or folder in the folder you want to alphabetize  
3. Select "Sort by Name"  

o Method 2  
1. Bring up the Bookmarks Manager ("Bookmarks -> Manage 

Bookmarks")  
2. Highlight any file or folder in the folder you want to alphabetize  
3. Right-click the highlighted folder and select "Sort by Name".  

• Mozilla Bookmark Sorter is a Java program which alphabetically sorts 
Firefox/Mozilla Suite/Netscape bookmark files (usually called "bookmarks.html").  

• Another option is to use Sort Bookmarks, a Firefox-only extension.  



Keyboard Shortcuts 

Command Firefox Internet Explorer 

Add Bookmark Ctrl/Cmd+D Ctrl/Cmd+D 

Back 
Backspace Win/Linux 
Alt+<- Win/Linux 
Cmd+<- Mac 

Backspace 
Alt/Option+<- 

Bookmarks Ctrl/Cmd+B 
Ctrl+I Win Ctrl/Cmd+I 

Caret Browsing F7 Feature Not Available 

Close Tab Ctrl/Cmd+W 
Ctrl/Cmd+F4 Feature Not Available 

Close Window Ctrl/Cmd+Shift+W 
Alt/Option+F4 

Ctrl/Cmd+W 
Alt/Option+F4 

Complete .com Address 1 Ctrl+Enter Win/Linux Ctrl/Cmd+Enter/Return 

Complete .net Address 1 Shift+Enter/Return Feature Not Available 

Complete .org Address 1 Ctrl+Shift+Enter Win/Linux Feature Not Available 

Copy Ctrl/Cmd+C Ctrl/Cmd+C 

Cut Ctrl/Cmd+X Ctrl/Cmd+X 

Decrease Text Size Ctrl/Cmd+-   

Delete Del Del 

Delete Individual Form Auto-
Complete Entry Shift+Del Del 

DOM Inspector Ctrl+Shift+I Win/Linux Feature Not Available 

Downloads 
Ctrl+J Win 
Ctrl+Y Linux 
Cmd+J Mac  

Feature Not Available 

Find Again Ctrl/Cmd+G 
F3   

Find As You Type Link ' Feature Not Available 

Find As You Type Text / Feature Not Available 

Find Previous Ctrl/Cmd+Shift+G 
Shift+F3 

  

Find in This Page Ctrl/Cmd+F Ctrl/Cmd+F 

Forward 
Shift+Backspace 
Alt/Option+-> Win/Linux 
Cmd+-> Mac 

Shift+Backspace 
Alt/Option+-> 

Go Down One Line Down Down 



Command Firefox Internet Explorer 

Go Up One Line Up Up 

Go Down One Page PageDown PageDown 

Go Up One Page PageUp PageUp 

Go to Bottom of Page End End 

Go to Top of Page Home Home 

Full Screen F11 Win/Linux F11 

Help F1 Win/Linux F1 

History Ctrl/Cmd+H Ctrl/Cmd+H 

Home Page Alt/Option+Home Alt/Option+Home 

Increase Text Size Ctrl/Cmd++   

Move to Next Frame F6   

Move to Previous Frame Shift+F6   

New Mail Message Ctrl/Cmd+M   

New Tab Ctrl/Cmd+T Feature Not Available 

Next Tab Ctrl/Cmd+Tab 
Ctrl/Cmd+PageDown Feature Not Available 

New Window Ctrl/Cmd+N Ctrl/Cmd+N 

Open File Ctrl/Cmd+O Ctrl/Cmd+O 

Open Link Enter/Return Enter/Return 

Open Link in New Tab Ctrl/Cmd+Enter/Return Feature Not Available 

Open Link in New Window Shift+Enter/Return Shift+Enter/Return 

Open Address in New Tab 1 Alt/Option+Enter/Return Feature Not Available 

Page Info Ctrl+I Linux 
Cmd+I Mac 

  

Page Source Ctrl/Cmd+U Ctrl/Cmd+F3 

Paste Ctrl/Cmd+V Ctrl/Cmd+V 

Previous Tab 
Ctrl/Cmd+Shift+Tab 
Ctrl/Cmd+PageUp Feature Not Available 

Print Ctrl/Cmd+P Ctrl/Cmd+P 

Redo Ctrl/Cmd+Shift+Z 
Ctrl+Y Win/Linux Ctrl/Cmd+Y 

Reload F5 
Ctrl/Cmd+R 

F5 
Ctrl/Cmd+R 

Reload (override cache) 
Ctrl/Cmd+F5 
Ctrl/Cmd+Shift+R Ctrl/Cmd+F5 



Command Firefox Internet Explorer 

Restore Text Size Ctrl/Cmd+0   

Save Page As Ctrl/Cmd+S   

Save Link Target As Alt/Option+Enter/Return   

Select All Ctrl/Cmd+A Ctrl/Cmd+A 

Select Location Bar Ctrl/Cmd+L 
Alt+D Win/Linux 

Alt/Option+D 
F4 
Ctrl/Cmd+Tab 

Select Next Auto-Complete entry 
in text field Down   

Select Previous Auto-Complete 
entry in text field Up   

Select Next Search Engine in 
Search Bar Ctrl/Cmd+Down   

Select Previous Search Engine in 
Search Bar Ctrl/Cmd+Up   

Select Tab [1 to 9] 
Ctrl+[1 to 9] Win 
Alt+[1 to 9] Linux 
Cmd+[1 to 9] Mac 

Feature Not Available 

Stop Esc Esc 

Undo Ctrl/Cmd+Z Ctrl/Cmd+Z 

Web Search 2 Ctrl/Cmd+K 
Ctrl+J Linux   

Win: This shortcut only works in Microsoft Windows. 

Linux: This shortcut only works in Unix/Linux. 

Mac: This shortcut only works in Mac OS X. 

1: This shortcut only works in the Location Bar. 

2: Web Search moves the cursor to the Search Bar and only works if the Search Bar is visible. 
If the Search Bar is hidden, this keyboard shortcut has no effect. 

© 2002-2004 David Tenser. 

These keyboard shortcuts have bee reprinted with the kind permission of David Tenser. 

 


